Page 1 of 1

Selling: Amiga 500

Posted: Sun Oct 11, 2020 1:04 pm
by Don Corleone
Hello - I have an A500 that I took out of storage a couple weeks ago. Fired it up and worked. Cleaned the case, blew out the dust, then reconnected it and now I get the 11 power led blinks from hell.... bummer. Anyway, if anyone is interested in making an offer I can ship it. Also has a working original Amiga monitor and original Amiga external drive.

Thank you,

Gino

Re: Selling: Amiga 500

Posted: Sun Oct 11, 2020 1:12 pm
by intric8
@Gino

Where are you located?

Re: Selling: Amiga 500

Posted: Sun Oct 11, 2020 4:04 pm
by obitus1990
Did you at least troubleshoot it for loose ICs as I mentioned in the reply to the PM you had sent me?

Re: Selling: Amiga 500

Posted: Mon Oct 12, 2020 11:05 am
by Zippy Zapp
Location? Where is it shipping from? Also, what brand and model is the Monitor and external drive?

Re: Selling: Amiga 500

Posted: Tue Oct 13, 2020 3:13 pm
by Don Corleone
Hi friends - I'm located in Chico, CA. The monitor and external drive I have are the original ones that I had with my A1000. The monitor is the 1080 and the drive is the 1010. However, before I sell anything, I'm going to give Obitus' PM response to me a try - he encouraged me to try re-seating the chips before I throw in the towel. I will do that and let everyone know.

All that said... I find myself greatly missing my A1000. I realize they are very hard to find now. I do still have my original A500 in my man cave, which runs beautifully and is still in exquisite shape. But I would gladly trade it and pay $$ for an A1000 with keyboard.

The A500 that I'm either selling (or trying to get working again), was my dad's...

Re: Selling: Amiga 500

Posted: Thu Oct 29, 2020 5:45 pm
by Don Corleone
Following up here. Re-seated the chips ~ same results. Something failed/died while I was cleaning it out with air and moving it around. I'm not going to worry about it anymore.

I do still have a working 1080 monitor and 1010 ext drive. The 1080 monitor has a very sensitive volume knob, crackles while adjusting/turning it, but works fine once settled. If anyone is interested, let me know.