User avatar
purpletentacle
victoria, bc

Posted Mon Jan 04, 2021 10:43 pm

hello amiga lovers

i remember fondly using an amiga in grade 7, im sure it was an amiga 500. i remember my cousin hooking me up with a disk of mod files and a mod player and listening to some songs in class

i just acquired an amiga 500 and an amiga 1000 after a long time of unsuccessful craigslist attempts. the previous owner said they worked fine when he stowed them away 20 years ago
they came with over 50 games in their boxes and i cant wait to try them. many of the games include the original purchase receipts and credit card receipts, its so neat to read those. the bundle also came with many joysticks and a mouse that half works (up/down fine, left right no workey) along with a bunch of books

the amiga 1000 is missing its keyboard but i hooked it up with the video RCA to my tv and it fired up no problem, it has a 256k ram expander on the front. its battery is bad, i will remove/replace it soon. the case is a bit scuffed but its a great looking machine.

the amiga 500 is missing its power supply and something to hook up the video to. i opened it up and the memory expansion had a leaky battery so i successfully desoldered it, my first component desoldering. the keys and case look aged, ill hopefully restore the colour once i fire it up and confirm it still works. the keys feel great.

i have a commodore vic20 as well. i used to have one when i was a kid in the late eighties, so when i saw one for sale in a local game store i bought it up right away.

im excited to have these great machines and i cant wait to spruce them up. i hope to gain some good repair and restoration experience that i can eventually pass on as a contributing member of the amiga world


thanks for reading
chad

User avatar
3D-vice
Germany

Posted Tue Jan 05, 2021 5:55 am

Welcome to The Hive! :D

User avatar
Zippy Zapp
CA, USA

Posted Tue Jan 05, 2021 11:14 am

Welcome and reading about more people getting back to Amiga always brings a smile.

User avatar
intric8
Seattle, WA, USA
Website

Posted Tue Jan 05, 2021 11:19 am

Welcome, purpletentacle! Interesting how many C=/Amiga peeps are up in BC! Very cool

If you have any photos of your gear, we love photos. =)
the amiga 1000 ... battery is bad, i will remove/replace it soon.
I wonder: what kind of battery could your A1K possibly have? Is it an internal board?

Do you have - not kidding - the Timelord? I've never seen one in-person before. I only know one other person who has one...

User avatar
purpletentacle
victoria, bc

Posted Tue Jan 05, 2021 4:46 pm

intric8 wrote:
Tue Jan 05, 2021 11:19 am
Welcome, purpletentacle! Interesting how many C=/Amiga peeps are up in BC! Very cool

If you have any photos of your gear, we love photos. =)
the amiga 1000 ... battery is bad, i will remove/replace it soon.
I wonder: what kind of battery could your A1K possibly have? Is it an internal board?

Do you have - not kidding - the Timelord? I've never seen one in-person before. I only know one other person who has one...
oh im not sure now that you mention it
i noticed that when i booted up it said it couldnt find the date/time or somethin like that so i assumed it was the same as the a500

User avatar
intric8
Seattle, WA, USA
Website

Posted Tue Jan 05, 2021 4:48 pm

i noticed that when i booted up it said it couldnt find the date/time or somethin like that so i assumed it was the same as the a500

Ah - that's just Workbench looking for a clock and very likely not finding one (at all). I was pretty stoked for a second there! ;)





Return to “Member Intros”