Page 1 of 1

1541C repair

Posted: Fri Nov 13, 2020 7:13 pm
by obitus1990
So, I picked up a 1541C drive about a year and a half ago (as well as a 64C) from a local for $100, untested (the standard "I don't have the right monitor/tv/blahblahblah). Well, of course, neither worked when I got them home. I was able to repair the 64C after finding some trace corrosion. Luckily, the 6581 SID was good, as were most of the other ICs. The PLA was bad, however, and I replaced that with a PLAnkton. Eventually, however, the 64 stopped working a year later, due to a dead CPU, so, I decided to use it as a donor for building a new SixtyClone. But, I never got around to fixing the 1541C until the last few weeks.

Symptoms: Powers on, but spindle keeps spinning, and red activity light does not light, will not read or write disks.
Fix: Swapped out one of the VIA 6522s and the spindle would stop spinning a few seconds after power on. Still, no temporary lighting of the activity LED, though.
Second fix: removed almost all ICs, found a broken trace under the large gate array IC and repaired it, all ICs were now socketed, and I could try them in on a known working board that had some of the same ICs (there is a variation from model to model -- the 1541C has a very short board and has a lot of the logic ICs condensed down into one IC and a hybrid IC).
The drive would then temporarily light the activity light upon power on. Still, it would not read a disk. It COULD sometimes read a directory if I had first moved the head of the drive all the way to track 1 and issued the directory load command. But, if the head was closer to the last track, it would not move itself outwards and back to read the directory. If I used the 1541 Diagnostic Cart's Head Excerciser tool, I could move the head back and forth, but not make it jump to track 1 or 18/35.
Mechanically, the drive works, because I could put another 1541's motherboard on the drive mech and it would work flawlessly, plus the head exerciser tool could move the mechanisms at least partially, so, there's still a problem with the logic board.

4th fix: Swap out the DOS ROM for JiffyDOS. The drive will now read! But, it will not format or write disks, but the head exerciser tool works properly (bump to track one, jump to track 18, jump to track 35, read the directory and BAM of the disk every time)f. I tried using my copy of Ultima V, which actually saves to disk as you play, and it asks you to insert the Underworld disk after you generate a character. Even though the correct disk is in the drive, it would error out and ask for the disk again. This made me suspect that the write protect circuitry was not working properly, and was stuck in the "ON" position. There is an IR LED on the front left side of the drive that emits light through the notch on a disk, which is picked up by a sensor below the disk. IF the light is blocked (by a write protect tab), the drive will not write to disk, as write protection is enabled. I did a DIODE test on the LED, and sure enough, it failed, so I installed a new IR LED. What do you know? It works perfectly now, reading, writing, and formatting, and passes all the 1541 Diagnostic Cart tests. Another weird symptom was that it wouldn't report the drive RPM to the diagnostic cart until I replaced that LED.

So, after getting it working, I decided to put the 1541C on a weight loss diet. I removed the old heater of a PSU, the 12V and 5V regulators and the bridge rectifiers from the board and replaced the whole power assembly with a modern Meanwell PSU. The drive probably on weighs about 3 lbs now versus what felt like 10 lbs before! Plus there is practically zero heat output.
IMG_0484 2.jpg

Re: 1541C repair

Posted: Sat Nov 14, 2020 5:01 pm
by intric8
Wow - that was quite the epic journey. Congrats on getting it working!

Which Meanwell PSU did you use instead? Was that difficult to install?

Re: 1541C repair

Posted: Sat Nov 14, 2020 11:41 pm
by obitus1990
intric8 wrote:
Sat Nov 14, 2020 5:01 pm
Wow - that was quite the epic journey. Congrats on getting it working!

Which Meanwell PSU did you use instead? Was that difficult to install?
It is a Meanwell RD-50A. It is not difficult to install, but you need to desolder the two bridge rectifiers, then bridge the connections there, as well as desolder the on-board voltage regulators and then bridge the connections between the pins on each of them as well (see in the photos where I have wire bridges installed where the aforementioned parts were). You will have to cut the wires from the big-ace step-down transformer that powers the beast and save the plug for it so you can then then use that wire with the screw terminals of the Meanwell. Just make sure you are sending 5V where it belongs and 12V where it belongs by tracing things out with a multimeter, else you'll release the magic smoke!