User avatar
Seattle, WA, USA

Posted Thu Aug 18, 2022 9:32 am

The other day I decided I should test my various copies of GEOS for the C64 and C128. GEOS was a Mac-like user interface that gave Commodore 8-bit users a rich and customizable desktop experience for file management, word processing and other publishing tools, spreadsheets and more.

I have original boxed versions of:
  • GEOS 2.0
  • GEOS 128
  • GEOS 128 2.0
I also have GeoPublish and a FontPack for my future serious publishing needs. <3

I used to live in Berkeley, California. I never realized at the time that the creators of GEOS were just a mile away over on Shattuck Ave! At least, they used to be. In fact their logo is taken from the clock tower of Berkeley University. Pretty cool!

To take full advantage of GEOS it's best to slap on some additional RAM. Back in the day Berkeley Softwarks created their own specialized RAM cartridge called the geoRAM - which pretty much only works with GEOS. But Commodore offered their own expansion RAM, too.
During the chip shortages of the 1980s, Commodore could not produce enough of its RAM Expansion Units (they eventually cancelled them). The GEOS operating system relied heavily on extra RAM and so the company behind GEOS produced their own memory expansion cartridge, called the geoRAM.
Chip shortages? That's weird. Who ever heard of chip shortages?

Over on my C128 I have an original 1750 RAM Expansion Unit (REU). I sold my C64 REU a while back because my Ultimate cartridges can provide an insane 16MB of RAM. I also can plug in my RAMLink for an additional 16MB of RAM, so I'm good to go in that department.

Before jumping in, I decided it was time to finally use my NOS shrink-wrapped 1351 I've had for ages just sitting on a shelf collecting dust.

One of the interesting things about GEOS is it allows for several types of input to move the pointer around the screen. They include:
  • 1350 Commodore Mouse: This mouse is wired like a joystick on the inside, so moving the mouse around feels a bit clunky. Honestly that mouse is more at home with games like Marble Madness, but it gets the job done with some work.
  • 1351 Commodore Mouse: This is the crème de la crème mouse for Commodore 8-bit machines. It looks and feels like an Amiga tank mouse, although it isn't compatible with Amiga. If only more software supported it... even in 2022! I'm looking at you, Eye of the Beholder Remake. :)
  • Joystick: Yep, everyone has a joystick. Worse-case scenario plug any joystick into port 1 and you can move the pointer around the screen, too. (It's honestly better than the 1350.)
  • Koala Pad: Wait - I can use a drawing tablet to move the mouse around? They supported that? Yep!
  • You could even use an Inkwell light pen! Talk about being ahead of its time. Take that, Apple pencil!
Anyway, I opened the box of the 1351 - again - "brand new" and never once used. A foam strip was still holding the roller ball in place.
"Like a virgin. Touched for the very first time!"

And as I was about to plug it into my C64, I heard something. I couldn't believe it! My mouse sounded like a maraca!

It made me a little sick to my stomach realizing I'd have to take a screwdriver to this gorgeous relic. But I popped it open after removing just a few screws and couldn't believe what I'd found.
Probably shipped from the factory this way. Great QC, Commodore!

Upon closer inspection, one of the legs of the cap that was rattling around in the mouse didn't even seem to have a single drop of solder on it!
You can even see the hole where the leg that was soldered in simply "slid out" somehow. Unreal.

After talking to some friends of mine who are electronics gurus (I am not) they quickly explained how I could solder in a new cap, and which side was positive vs negative. One even mailed me a brand new cap to put into place with nice long legs for easy soldering (thanks, Rob!).

"She's got legs...!"

The new cap is the black one at 2 o'clock.

The final test was to plug her up to a machine and test it out. Rather than test on my C64, this time for some reason I decided to fire up my C128D. But I used the C64 version of GEOS 2.0. Within minutes, I was here:


Man, that felt so good to provide some tangible value to the world. I reached for the floppy disk lock to pop out the disk and put in a new one. I wanted to try out GEOS 128 to start testing my disks - you know: my original plan from days ago. I put the new disk in the drive and felt something give. I tried to load the program and it couldn't find the disk. I reached back out and that's when I realized...

Holy hell what was going on?!

I took the case off the C128D(cr) and thought, for the billionth time, I wish they'd made an Amiga 1000 CR. You know, one with a metal case in a 'cost reduction' move before it had been discontinued. I just love the 128D's metal case in that low-height form factor. Super solid, never yellows (except the plastic front face), built like a little tank.

Anyway, I looked inside and to my utter astonishment I discovered the post that attached to the outside lever had completely come apart. How this happened I honestly can't even begin to understand. It's a metal rod that fits into another metal piece that lets you open and close the head of the drive. And those two pieces are a VERY tight fit. In fact, in order to fix this problem I needed to use a pair of vise grips and a hammer. And I had to hit that sucker hard several times to put it back together.

I felt like I'd become a mechanic working on a car.

The key to this repair is making sure the rod is inserted into the other part properly in the exact orientation, otherwise the lever on the outside of the case won't go on correctly.

All this for wanting to test some software. But you know, guys? It's not always about the destination. In this hobby, it's often about the journey.


I soon discovered that my drive was fully repaired and worked perfectly. However, my GEOS 128 and GEOS 128 2.0 won't boot for some reason. One breaks during the middle of booting up and spits out a few lines of code. That's never a good sign. The other simply boots into infinity.

What got me started on this whole project was one of my friends mentioned the copy protection of GEOS was remarkably punishing. In his recollection, it was quite easy to destroy your original disks.

Now I wonder...

More disk sleuthing and retro-computer archeology coming up! But hopefully I'm done being a mechanic for a little while.

User avatar
Zippy Zapp

Posted Thu Aug 18, 2022 8:06 pm

Wow what an adventure, haha.

GEOS was an amazing software to use back then. I have yet to boot my old originals up. The copy protection was good and IIRC used serialization to attach a serial number to all your original disks so that they would only work on the first copy of GEOS you started it from. Of course tools like Maverick made that no big issue but it was a thing that you couldn't take your app disks to a friends and use it on his GEOS.

Fun times.

Return to “8 Bits”