User avatar
intric8
Seattle, WA, USA
Website

Posted Tue Nov 03, 2020 1:27 pm

Nice!!

User avatar
vfx_geek
Poland

Posted Sun Jul 11, 2021 6:42 am

Hi!
I have a Aiptek HyperPen 6000 and trying to make it work with my Amiga 600. I have powered it from my laptop, using a PS2-USB adapter, and connected to Amiga with a serial 25-to-9 pin adapter.

As far as I know the only driver which supports this tablet is FormAldiHyd. Unfortunately this driver completely doesn't work for me. Returning an error when trying to start it.

So far I had the most luck using Tableau.Pro, which even though doesn't support this tablet, partially works when set to Genius or Summa mode. But the X and Y axis are swapped. Atleast I know that the tablet is not broken.

Could anyone please share their ToolTypes Settings for FormAldiHyd? And also how are you starting it?

Thanks,
Lukas
PXL_20210711_121705741-1.jpg

User avatar
Mixel

Posted Sun Jul 11, 2021 7:05 am

Does it bring up the same error when you click on the FormaldiHyd GUI icon?

I think Formalin only works from CLI, so you can put it in your user startup etc.. It has no GUI, so it just seemed easier for me to use the GUI version. (particularly as i kept swapping between drivers/tablets and settings)

It should have come in the same package.. http://aminet.net/package/driver/input/FormAldiHyd - it needs MUI though. :(

Here's a screenshot of my FormAldiHyd tooltypes, and the icon:
Screenshot 2021-07-11 145003.png

User avatar
vfx_geek
Poland

Posted Sun Jul 11, 2021 7:27 am

FormAldiHyd shows a different error. I've installed MUI specifiacally for this - but it's a shareware.
PXL_20210711_141355609-scaled.jpeg

User avatar
Mixel

Posted Sun Jul 11, 2021 7:54 am

My MUI isn't registered either.. That shouldn't matter. How much RAM do you have? And do you have a CPU upgrade of some sort? I've not tried the drivers on anything below an '020 - I'd imagine they work.

I'm a bit stumped really, i don't know why it wouldn't work. :(

I think I'd put Formalin on a Workbench floppy and boot from that, run formalin from the CLI and see if the error still happens? No chance of conflicts with any software or your workbench installation then. (not a solution, just to help troubleshoot it)

User avatar
vfx_geek
Poland

Posted Sun Jul 11, 2021 8:09 am

I've got a stock CPU, but memory expanded to 2 and 8 MB, WB 3.1.4. I might try your sugestion with the floppy boot... or I'll just have to get another tablet - maybe a Wacom :)
Thanks !

User avatar
vfx_geek
Poland

Posted Thu Sep 09, 2021 11:46 pm

Mixel wrote:
Tue Nov 03, 2020 8:50 am
My A1200's motherboard is on its way to be recapped so I thought I'd have a go at art with my UAE backup of it's CF card.. (I'm not worried about the motherboard in the post, honest! :cry: )

But.. I got my Serial Wacom running in WinUAE!!!

.. I don't know what went wrong last time(s) but I've figured it out now. Now I get to try the surreal experience of Photogenics at 1080p with RTG and tablet pressure.. I'll definitely do a part 2/addendum to my tablets video now as this is pretty exciting.. (and surprisingly gives me a reason for having 2 graphics tablets, that's unexpected!) - I might stream this setup tomorrow, too.
Hi Mixel! How did you connect your serial tablet to WinUAE and what configuration did it require to make it work? I'm building a Pimiga and wondering if it's possible to connect any sort of tablet to work with FS-UAE.

User avatar
Mixel

Posted Fri Sep 10, 2021 12:21 am

I couldn’t get it working in fs-uae when I tried it but that may have been I didn’t know how to get to the exact command line options working. In WinUAE there’s an interface with a complement of options for different settings that seem missing from FS. I’d be interested if anyone got this working on a Pi too, as ArtEffect is too power hungry for my ‘030 really!

https://fs-uae.net/docs/serial-port - too confusing for me, haha. Maybe once the serial port is detected in workbench on fs-use the rest is plain sailing though?

I used a generic usb-serial adapter. Weirdly this wouldn’t work at all whatever I tried with my non-Wacom tablets, only with the Wacom, even though they work on my real Amiga setup.. So WinUAE’s emulation can’t be exactly perfect either. I’ll get the wacom running on WinUAE again today and take screenshots of the serial settings. :)

User avatar
vfx_geek
Poland

Posted Fri Sep 10, 2021 12:41 am

Cool! I'm currently hunting for a Wacom serial tablet on ebay, unfortunately most of them are sold without the pen, or not shipping to Europe. I will definitely try making it work on FS-UAE once I have one. Perhaps I'll experiment with USB tablets in the meantime.

User avatar
vfx_geek
Poland

Posted Fri Sep 10, 2021 1:36 am

BTW, on my Linux PC with Intuos 5, in FS-UAE when I move the pen over the tablet the cursor in Workbench just moves out of screen. Which means FS-UAE gets input from the tablet, but probably lacks a driver to properly handle it.
This is promising but I need to test it with older tablet.





Return to “Hardware”