User avatar
Mixel

Posted Thu Oct 29, 2020 8:10 am

I've spent the last day thinking I'm going insane.. But I SEEM to have a way to de-flicker an Amiga if you have the following devices/software.. :o

An Amiga (duh)
OSSC (Though maybe retrotink etc work too?)
Elgato HD60S+ (I THINK this is critical, YMMV with other 60fps capture cards?)
OBS Studio.. (ed: Or StreamLabs OBS)

I have my OSSC outputting to a 1080p display, so I have it set to Line multiplication x3 for most amiga screen modes (the linemult setting is critical to this.. You may have to try different options, and turn off/on your OSSC a few times..)

The Elgato has a very low latency preview window in OBS, certainly low latency enough to play most games, and to draw, etc.. So you can set a full screen preview window and run your amiga through that.. Until yesterday interlaced modes appeared shaky and as unusable as ever.. Previously I'd be able to take the edge off by selecting the source in OBS and going through the deinterlace options.. So I tried that. I cycled through every single variation of Deinterlacing and scaling options for the source, fiddled with the linemult on the OSSC, Then, eventually.. I get no flicker.

You need to set de-interlacing to "Disabled" (many of the other options show different degrees of flicker)
Scaling settings - Doesn't matter, but to me Lanczos looks nicest on my Amiga

I have a picture now that beats the cheapo HD video converter I used to use, with LOWER latency/input lag, it's perfectly crisp. It still displays some motion interlace artefacts but nowhere near as badly as it did on the HD Video Converter.. They can be reduced by using some of the deinterlacing options in OBS at the price some IQ and responsiveness (Yadif and Blend). "Disabled" is best IMO.

edit: To figure out how much of this is OBS' settings I thought I'd try Streamlabs OBS.. Apparently - it's NOT OBS' settings.. The flicker isn't displaying in SLOBS either right now - SLOBS has no de-interlacing settings at all! - so it's definitely the combination of the OSSC and the Elgato, somehow.

I was going to eventually buy an Indivision AGA but now I don't need to at all..

One interesting thing is if I switch the monitor over to the Amiga (the display is connected to a passthrough from the Elgato) i have an "OUT OF RANGE" banner on my monitor, and Amiga's dispay overlaps/doesnt fit on the display. You will likely have to try different LineMult modes on the OSSC, some display blocky non high-resolution style deinterlacing in OBS, others flicker like crazy. Each linemult setting I'd turn off and on the OSSC, toggle over to a scene in OBS that doesn't involve the Elgato, then switch back (which turns the Elgato's feed off and on again.)

I'm so happy with this. I'm think I'm still going to continue to run my Amiga in HighRes normally as I prefer *zero* latency and being able to run it directly on the display without the middle-man, but if/when I want to draw (or stream!) interlaced modes I now have the perfect solution for that.

This may eventually end up being my main way of displaying the Amiga. I need to make a nice widescreen Amiga border. I'll upload that if/when it happens. :D

I don't know if this is useful info to anyone else - maybe.. Maybe not? It might work with other capture cards etc though so maybe it's useful info to someone?

User avatar
mscdex

Posted Thu Oct 29, 2020 8:15 am

Which Amiga(s) did you test this with?

User avatar
Mixel

Posted Thu Oct 29, 2020 9:38 am

A PAL Amiga 1200 plugged via RGB Scart cable into the OSSC.

So it should apply to all Amigas, I think? :)

——

Yup, streamed and recorded from it now. Drew a bunch of pics in interlaced screen modes last night. No problem at all. It’s stable and consistent and not just a temporary glitch I fumbled into by mistake, haha.

Elgato HDs+ & OSSC fixes interlace flicker.





Return to “Hardware”