User avatar
obitus1990
New Orleans, LA, USA

Posted Thu Apr 01, 2021 8:00 pm

This has been an interesting learning journey to build this card, since the documentation and source was never released, thanks to the person who threatened to clone it and made Stephen Leary quit the Amiga scene.

Physically building it was not a challenge, as it is all manageable sized SMD components. Maybe the CPLD was a little bit of work to prevent and/or remove solder bridges, but, otherwise, it was a simple build. Especially since the official PCBs are sold pre-populated with passives on the underside. All the work to be done was on the top side of the card, except for desoldering some resistor networks on the underside so that buffers could be used.

The interesting part came in when programming the CPLD. I didn't have a xilinx programmer, and I tried to improvise with a generic JTAG progammer (USB FLashCat) and its SVF player, after converting the .JED firmware to SVF format in ISE Impact. It didn't work. I then learned that it could be flashed using a Raspberry Pi, and followed the instructions given here:
https://linuxjedi.co.uk/2020/12/01/prog ... pberry-pi/

It worked like a charm, and after installing it into my A1K Red A500+, it booted right to the KS screen, and booted from floppy just fine, so, there were no soldering errors...hooray!

BUT, the IDE wouldn't work. I tried two different CF cards and two different adapters, to no avail. AlenPPC told me that I could modify one of my existing CF adapters to make it work, and doing so would also remove the LED activity light on said adapter, which I will probably try tomorrow. I have to remove two transistors, it seems. In the meantime, I decided to try a DOM (disk-on-module) I had lying around with a Workbench 3.1.4 install on it...and it booted right up! I am using the firmware that Stephen released yesterday, and it seems to have fixed the long boot times I have seen in Youtube videos, and also some other random bugs that caused corruption during long writes to the CF card.

I'll run it through some tests tomorrow and see what I get...

Pics, or it didn't happen:
IMG_0901.jpg

User avatar
obitus1990
New Orleans, LA, USA

Posted Thu Apr 01, 2021 9:06 pm

Obligatory Sysinfoporn:
IMG_0902.jpg
IMG_0903.jpg
IMG_0904.jpg
IMG_0905.jpg
IMG_0906.jpg

User avatar
EzdineG
Springfield, MO

Posted Fri Apr 02, 2021 1:44 am

Grats, and welcome to the club!





Return to “Hardware”