User avatar
dargrz1977

Posted Wed Sep 15, 2021 3:49 am

- After hard reset / you see bootselector (LEFT+RIGHT BUTTOM MOUSE) on kickstart 3.2. It looks like you want to run the program from DF1 / DF2 on the Amiga 2000 and consequently it will not start as it refers to DF0: Then the DF0 drive freezes: Reset the computer solves the problem. You can see LED DF0: blinking during operation.

- After a hard reset / you see Wokrbench. In the case of Amiga 2000HD the program wants to mount / run with DF1 / DF2 readable floppy disk but not working with DISKCHANGE or after hard reset you see bootselector (LEFT+RIGHT BUTTOM MOUSE) kickstart 3.2 it will not start as it refers to DH0: (hard drive). Then the DH0 drive freezes: Reset the computer not solves the problem. You can see LED DH0: (Hard Drive) blinking during operation.

-For Amiga 2000 without disk, reset is good for Amiga 2000HD, reset is not good. Checked in programs that do not work with DISKCHANGE under workbench.

I wonder if it is possible to somehow change the priority for DH0, so that in the case of Amiga 2000HD it is possible to force the first other drive, eg DF1. Maybe that's the key, as the bootselector (LEFT+RIGHT BUTTOM MOUSE) on kickstart shows boot priorities in 3.2.

User avatar
dalek

Posted Wed Sep 15, 2021 7:28 am

A 2000HD is a regular A2000 with an A2091 card. Diskchange and 4 FDDs works fine.

Can you please try:

Internal DF0: - set to DS0 put at end of cable after the twist
Internal DF1: - set to DS1 and put in the middle of cable before the twist
External gotek DF2: - set to DS0
J301: closed

That should work. If it doesn't you have something else going on.

I notice you also have:
Supra 8MB
A2091 - how much RAM installed?
GVP GForce 030 - how much RAM and is it configured all Zorro II or Zoro III?

I think your setup would work best if you removed the A2091 and used the SCSI on the GForce configured as Zoro III 32-bit RAM. Also ditching the Supra 8MB and maxxing out the RAM on the GVP would give you best performance.

The SCSI on the A2091 works best with some Zorro II RAM on the card. But you've filled this address space with the Supra. The SCSI on the GForce can handle both those drives and the SCSI2SDs as well.

Also worried with 2x HDDs and all those cards your PSU might be dropping voltage and struggling - check 5V line when fully loaded and if ~< 4.9V consider recapping/replacing your PSU with a modern one.

User avatar
dargrz1977

Posted Wed Sep 15, 2021 7:48 am

Thanks for the tips. I just set it up. And I'm not saying it doesn't work. Because it works, but the system hangs after restarting Workbench, because I put the disk into the DF1 / DF2 drive, which cannot be dismounted with the DISKCHANGE command. I'll check it again today. The A2091 is BOOT turned off because it is not working with the GForce 030. So it is automatically disconnected. Not on the ZORRO list. It is only in a socket without power. The A2091 has no memory because it doesn't work with the GForce 030 like the Supra 2000. The Supra 2000 usually gives me a fast 8MB (16bit) plus a 1MB chip. It is useful when I turn off the accelerator programmatically, because then I do not have GForce and I do not have 8mb (32bit) of memory. GForce only works with memory as BOOT. Gforce sums it up as BOOT. If I start with A2091 (BOOT), GForce only gives me accelerations without memory. Greetings

User avatar
intric8
Seattle, WA, USA
Website

Posted Wed Sep 15, 2021 9:22 am

My Amiga 2000 is also setup with a rev 4 (green PCB) G-Force 030 @40Mhz. I use that card for everything as it solves most problems all on its own. The machine sports the original dual floppy drives. I use an external GoTek on occasion in rare circumstances.

I have the G-Force maxed out in RAM, thus no other RAM cards are really needed. Not with what I do, anyway. The accelerator is great, too.

The card powers a long SCSI chain that includes the original 40MB HDD, which the machine boots off of. It also drives an internal SyQuest (used for backups only) and 2GB SCSI2SD HDD which is where I install all of my software. I use the card's external SCSI port for a Zip Drive, too.

The A2K also has a megaChip upgrade for 2mb chip RAM.

At the end of the day, hats off to my old A2K's PSU!

That all being said, even though the machine can obviously have a lot more cards inserted I don't really need any. So there's just a lot of space in there. I've pondered adding a Serial Port card to add more ports, but I've procrastinated.

The G-Force kinda hits all the right buttons for that machine. I don't use the A2K for storage of other cards not in use, fwiw.

Now, mine is running OS 1.3 and not anything recent. And it's as solid as a rock.

After all of your tests you've done thus far, do you think your issue is software-based or hardware at this point?

User avatar
dalek

Posted Wed Sep 15, 2021 7:54 pm

"...It is only in a socket without power" that is not right - it will still draw power through the Zorro slot so will be powered up regardless of jumper. The jumper just disables the boot rom - you still need to set JP1 to disable the RAM and prevent it from decoding the RAM address space even if you have just removed chips.

Honestly I would just remove the A2091 to get everything working as expected then add it in after if you really must.

User avatar
dargrz1977

Posted Thu Sep 16, 2021 4:43 am

Jumper on, memory off, because it is not there, as I mentioned earlier. Yesterday I took out all the cards and only left the Gforce. The problem is still the same. When I load the HDF GOTEK drive program onto the GOTEK drive while starting Workbench on the Amiga 2000HD, the drive is read during startup, which is visible on the device and stops at track number 40. After booting, just open the folder from the DF2 drive: (GOTEK) and restart the AMIGA 2000HD freezes as mentioned before. I note that this only happens with ADF files (FLOPPY) that are read in Workbench but cannot be changed DISKCHANGE. XCOPY, HDFGOTEK and other programs. Every floppy disk with WORKBENCH or games WINGS, POPULOUS etc, others that can be unmounted with DISKCHANGE work and you won't see any problem with AMIGA 2000HD. Others are not recognizable by Workbench or report a reading error and you will not see this problem either.

User avatar
dalek

Posted Thu Sep 16, 2021 8:03 am

What is this "HDF GOTEK" drive program? Is that the only thing not working?

User avatar
dargrz1977

Posted Thu Sep 16, 2021 8:11 am

Sorry. Gotek Floppy Drive Autoboot.HFE on Slot 000.

User avatar
dalek

Posted Thu Sep 16, 2021 8:14 am

What firmware are you running on your Gotek? Have you tried the latest FlashFloppy release?






Return to “Hardware”