User avatar
ncstebb

Posted Fri Oct 29, 2021 7:46 pm

Hi all,

I recently got hold of a non-working Amiga 1000 with Phoenix motherboard. The previous owner said it was working until he knocked a side RAM expansion.

I've tested most of the main chips in an A500 and found them to be faulty. I've replaced the CPU, CIAs, Paula, Denise and Gary with ones that seem to work. I've put in a different Agnus 8372A that I took from another non-working Amiga so I'm not certain it's good. (Can I test this by putting it in my A500 which currently has an 8371??)

It's currently giving no video signal. I've tested the Hsync and Vsync with a scope and they are both giving a flat 5V.

I'm probably a bit out of my depth. Hoping for suggestions about what I should be trying next?




Here is a more complete list of things I've tried...
- Removed floppy in case of shorts
- Removed rear RF shield in case of shorts
- Tested the PSU output... all good, Tick gives 50Hz
- Tested CPU, CIAs, Gary, Paula, Denise... all faulty and replaced.
- Replaced Agnus 8372A with another that us untested.
- No sound output on startup
- Caps lock lights up when power first applied then behaves normally toggling when pressed.
- Ran for a while and felt the chips...
- Warm to hot: CPU, Agnus, Paula, Denise
- Cool to warm: Gary and the CIAs
- Tried starting without kickstart roms - no effect
- Checked activity on Gary pin 21 on startup. I read that this might give an indication if the KS roms are being accessed. It goes straight to 5V and stays there. I'm not certain but I think it's not getting to loading the KS.
- Checked the reset pin on the CPU, sitting at 3.18V, didn't seem to change when I hit the Ctrl-Amiga-Amiga

User avatar
Crispy

Posted Fri Oct 29, 2021 11:02 pm

I hate to say it, but it doesn't sound good. It's unusual for all those chips to go bad simultaneously, so the damage may be quite extensive, and may extend to the discrete logic chips scattered around the board.

Before diving back in, go ahead and download this schematic.
https://www.amigawiki.org/dnl/schematics/A2000_R6.pdf

It won't help in tracing signals, but it does give you a handy reference for pinouts of all the major chips.

I would start by looking at the reset again, but this time from power on. You should see the reset line stay close to 0 volts for several hundred milliseconds after the power supplies are up to operating voltage.

Next, I would look at the following signals on the processor: BEER, HLT, AS, DTACK, and CLK. The CLK should be about 7 MHz. BEER and HLT should be high, and AS and DTACK should be toggling. If you're not seeing a good CLK signal at the CPU, then check the 28 MHz pin on the Agnus chip.

Also, the HSYNC pin on Agnus must be pulled high during and after power on reset. If Agnus sees this pin low after it comes out of reset, then it will switch over to external timing, and will expect a good clock on the XCLK pin. If this happens, then the entire system will be dead in the water.

That's all I have for now. Good luck and good hunting.

User avatar
McTrinsic

Posted Fri Oct 29, 2021 11:56 pm

It’s not that easy to fry a Phoenix 😉.

Could you tell us what exactly it means to ‚not work‘?

Any LEDs? Black screen or grey screen?

Do you have a DiagROM at hand?

As I’ve been through similar situations I’d wait a moment before disassembling the diva.

User avatar
ncstebb

Posted Tue Nov 02, 2021 3:33 am

Sorry for the slow response.

I'm pretty sure there is no video signal. I have a screen that works with other Amigas and it say's no signal with the Phoenix. HSync and Vsync on the RGB port give a flat 5V. The caps lock lights up when I power on then goes out (still lights up as normal when I press it after that) The Power LED is broken but the leads for it show 5V. No sound output on startup.

I think I'll need some better test gear to check the signals. My USB oscilloscope is maxed out at the frequencies Crispy suggested I check. Here is what I've found on the CPU pins with the gear I have...
- Reset: does go low when it's switched on. I think it's about 1/4 second and then it goes high. It doesn't change when I try to reset with the keyboard.
- CLK: reads low with a logic probe. My dodgy scope did detect something though but the frequency seemed to be maxed out.
- BEER and HLT: Both High.
- AS was low on my logic probe.
- DTACK was high on my logic probe.

I also tried to check the suggested signals on Agnus but failed thus far. I did confirm the +5V pin reads high. Also the Agnus HSYNC pin goes low and stays there as soon as I power on. @Crispy: I think you said this is a bad thing?

I should be able to get hold of a better scope to test further.

User avatar
McTrinsic

Posted Tue Nov 02, 2021 4:35 am

Best option would be a DiagROM.

Any SCSI connected?

User avatar
ncstebb

Posted Tue Nov 02, 2021 5:19 am

I'll have to order myself a DiagROM.

I think the previous owner had a SCSI device connected. I was wondering if I might need to change some jumpers because of this.

It also occurred to me that I might have a missing chip. U70 and U21 aren't populated on my board. I noticed these were populated on the Phoenix board shown on amigaresource.cx.

User avatar
intric8
Seattle, WA, USA
Website

Posted Tue Nov 02, 2021 7:27 am

I also have a Phoenix, and McTrinsic was spot on when he called the board a "diva." It can be so finicky at times it originally made me think it was dead when I got it all the way from Australia.

I removed and reseated chips in the beginning. Not sure about jumpers, but the built-in SCSI was great for me after I got the board to boot. My problem was insanely simple (and annoying!) once I figured it out.

On my board there is a hardware switch that lets you flip the boot sequence between the floppy drive and another external drive. My board only had the floppy, but at some point either during its being shipped half-way around the world, or by me when I installed the board into a donor case the switch had been flipped to External Drive. That tiny change of switch position was all I needed to get mine to finally wake up. Without it, my board acted exactly like how you describe yours. All the lights came on, but it was (I realized later) waiting for a nonexistent drive to deliver the goods. So, it just sat there with a black screen appearing broken.

I worked on that thing for hours.

Then, at a stage where I was about to quit, I simply flipped that switch turned and power on. I was SO close to calling it quits. But then it suddenly sprang to life!

I'm not saying your board has the same problem, and I'd bet you don't have a switch for your board. I do wonder if it is waiting for an external drive to load workbench (probably not but be good to check that off the list!). If you don't have a physical switch, then that would indeed be driven by a jumper.
U70 and U21 aren't populated on my board.
I don't remember if mine had those populated, either. If you want me to check I can pull the case off and see. I could also show you the Agnus I'm running.

I'll see if I can find any photos while I'm having my breakfast in the meantime.

Good luck!!

User avatar
McTrinsic

Posted Tue Nov 02, 2021 8:49 am

The pic on Amiga.resource.cx is from me and a good start for a standard 2MB board.

Please switch SCSI off (L35?).

If the SCSI does not find anything it may take a *really* long time l to boot.

User avatar
ncstebb

Posted Sun Nov 07, 2021 1:20 am

I haven't had a lot of time for this, but I tried changing the L35 jumper and checked a few other jumpers based on the manual. No luck so far. I still need to get my head around the kickstart switch and boot drive switch.

A DiagROM is coming but will be a month in postage.

Intric8: If you don't mind checking to see if you have U21 and U70, it might help. I think the previous owner would have told me if any required chips were missing, so I'm hoping it can run like this.

Anyhoo... I don't expect to make progress any time soon... thanks again for the help and I'll keep you posted.

User avatar
nullsleep

Posted Sun Nov 07, 2021 4:32 pm

ncstebb wrote:
Tue Nov 02, 2021 5:19 am
I'll have to order myself a DiagROM.
I would suggest grabbing a TL866+, an adapter for 27C400/etc and some 27C400 eeproms instead.

It won't cost you much more and will definitely pay itself over time.





Return to “Hardware”