User avatar
Signman

Posted Sat Nov 13, 2021 1:38 pm

Maybe this is related to a previous posted issue with my 4000. That problems can't be recreated but now this:



I decided to install the latest roms 3.2 into this machine after a successful install of software earlier.

Initially it just didn't seem to work so after many attempts, reseating etc. I tried with old roms. Same thing. Then I discovered if I just let it run for a while
( eight minutes) it will boot into system. Everytime will boot if I just wait.

So, tried two button mouse hold down for early boot. No luck, but would probably come up if I waited real long.
Tried without CF card just to wait for prompt same amount of time.

Floppy cable seem to connect and DF0 Gotek works.
Warp 040 seated well.
No Zorro cards are attached.
Memory shows all is well.
Ran some diagnostics from Gotek and couldn't find any issues.

So what gives?
Signman is online now Report Post

User avatar
McTrinsic

Posted Sat Nov 13, 2021 4:20 pm

A4000T or D?

Is the IDE populated?

Or only SCSI / the accelerator- port?

User avatar
Signman

Posted Sat Nov 13, 2021 4:44 pm

The ide has my cf card hard file and the scsi comes off the warp card.
That said even when cf card is removed and scsi drive is hooked up It still takes forever to boot from gotek.

So as long as I don’t boot from hd what settings would the system be looking at and take so long to boot. Two button hold on mouse doesn’t help.

User avatar
McTrinsic

Posted Sat Nov 13, 2021 5:18 pm

I asked because the A4000T may wait for the IDE if no drive is connected. That’s why there are IDE terminators for the A4000.

Did you set up the CF on the actual hardware? OS3.2 loads some rom parts from disk. Maybe that’s where the issue lies if some flags or parameters aren’t set right.

We might need more details. E.g. filesystem, partitions, buffers, RAM, …

User avatar
Signman

Posted Sat Nov 13, 2021 6:16 pm

I set this 32 gb CF card up on Winuae updated a 3.1.4 to 3.2 with it.
Put it in the 4000 using my 3.1 roms, everything works good.
Get new roms installed then this long delay which it does with the 3.1 roms now also.
Can't get any mouse hold down boot menu.

No scsi devices connected now just Gotek which boots with rest of the system eventually.

My card comes in HD tools as a scsi drive type SDCFHS-0 32GB SCSI=0 LUN 0
FFS file system 2gb DH0 and 28gb DH1 ( I know,poor choice_
128mb ram on warp card and 16 gb on man board along with 2mb chip

User avatar
A1-X1000
Toronto, Canada
Website

Posted Wed Nov 17, 2021 4:51 pm

hmm 8 minutes is long time booting up from on board IDE...the only time I've heard of a long boot time is when the IDE is empty and booting from scsi and that's why the IDE terminators were made. Did you check HDToolBox to make sure there's no other devices other than the SD card your booting off your onboard IDE?

I've never used UAE to setup a HD for a real Amiga so don't know if maybe that has caused an issue with the new OS3.2 roms installed? Perhaps if you have an extra CF card lying around try a clean OS3.2 install with that and see if the delay goes away

User avatar
McTrinsic

Posted Thu Nov 18, 2021 2:42 am

Sorry I didn’t find if you specified if it is an A4000d (maybe towerized) or an A4000T.

User avatar
Signman

Posted Thu Nov 18, 2021 7:11 am

It’s a desktop.
3.2 has nothing to do with it, does the same with 3.1 roms
Didnt have that issue before. Even if i disconnect all scsi and ide drives and try with just gotek, still the same. Even then 8 minutes to get insert disk prompt.

It’s as if I accidentally removed a jumper or configured something wrong, but damn sure I didn’t. I can insert and older CF OS in boot and the same. Take scsi cable off warp card (cd drive works like crap anyways) and no change. Try to boot with two button hold down and even that takes the same amount of time.

User avatar
McTrinsic

Posted Thu Nov 18, 2021 10:10 am

Do you have a real floppy for testing?

User avatar
Signman

Posted Thu Nov 18, 2021 10:16 am

I did connect one to back of computer but putting another one in DF0 is what I was thinking also. Maybe the Gotek , although working, making the system hang on boot up. I will pull one out of another and test.

Edited after this:
New Gotek doing same thing. I guess a regular floppy could be tried also. Will do it next





Return to “Hardware”