User avatar
Seattle, WA, USA

Posted Thu Mar 16, 2017 10:30 pm

As ZippyZapp wrote in a previous post, there are a lot of interesting options when it comes to replacing a battery in an Amiga. And replace them we must - or, at the very least, remove them. And in that post, I related my personal bad fortune of having replaced my battery but never having the thing actually save my date and time on a reboot. I thought I had done everything perfectly, but it just didn't work. I've finally figured out why. More on that below.

In terms of battery replacements, ZippyZapp walked us through the choices out there.

There's the standard barrel battery, which has to be soldered and de-soldered to replace (not awesome, but they last a really long time). This is the kind of battery Commodore used decades ago, and are honestly the reason so many Amigas die. The barrel batteries, over a long period of time, will start to corrode and leak acid. Some ultimately destroy the motherboards they were soldered onto, an all too common and painfully tragic way for these old machines to die. My philosophy is: why replace a flawed component with yet another future problem?

Note: this article assumes your IC clock chip is working. If you aren't sure, I highly recommend downloading and installing SysInfo if you haven't already. (See here on how to transfer files to the Amiga from a PC.) Fire it up and look on the right-hand side of the screen under "Internal Hardware Modes." The first item is "CLOCK" and, hopefully, it says, "FOUND". If it does, you're good to go.

I went the coin-battery route for my Amiga 2000, supplied by Amigakit for only a few dollars. The obvious benefit being the battery can be easily swapped when necessary without desoldering junk ever again. What's also nice about this option is that it comes with a holder that contains a protection circuit, which prevents charging of the coin cell. This is important, because if you charge a non-rechargeable lithium battery, it could potentially explode. The holder has circuitry to prevent that.
New lithium battery kit to install.

The following is a guide to remove and replace a battery for an Amiga 2000 running Kickstart/Workbench 1.3. This delineation is important, which I'll explain later, as the classic 1.3 OS on original hardware has a particular gotcha you'll (sometimes) need to address in order to it get working. This is for informational purposes only. AmigaLove is not responsible for your hardware or physical safety. Please take the proper precautions and do this work at your own risk.

Step 1: Remove your motherboard
This doesn't really require a lot of explanation. You will have to remove it completely from the case, remove the PSU, and the heat-shield underneath the motherboard. Put all your screws to the side.

Step 2a: Remove your old battery If your battery is already removed, skip to Step 3.
If your battery hasn't been removed yet, get that sucker out of there!

When I first acquired my 2000, the first thing I did was pop the case off and remove the battery. The easiest way to do this is to remove the floppy drive bay, then grab a pair of needle-nose pliers. If you grab ahold of the barrel battery with your pliers, slowly rock the battery back and forth. After about 2 minutes or so, it will (or should) break off the board. This will leave the soldered legs of the battery stand broken off in your motherboard, but it doesn't hurt anything. You really don't need to remove your motherboard entirely from the case to get the battery out. That is an unnecessary waste of time... unless you plan on putting the new battery in at the exact same time. Which is why you're here. Read on.

Step 2b: Clean the motherboard
Once the battery is out, you need to clean off the acid dust and built up residue on the motherboard as best you can. You might start with a paper towel with some vinegar and water on it (not dripping, but damp). For hard-to-reach places, some Q-Tips will come in handy. Some recommend using a soft toothbrush. In any case, do your best to remove the acid. Hopefully your board is still OK. In my case, I removed enough of the green coating in one spot that I used a special overcoat pen to draw some new coating.

Step 3: Installing the new Battery
I needed the following supplies. There are certainly better equipment options out there, but this is what I used and it worked fine for my needs. If you've never soldered (or de-soldered) before, it's worth looking up a few videos on YouTube first to understand the basics and best practices. The trickiest part is the desoldering part, really. A little practice and it's not so bad once you get the hang of it.
Most of the tools needed to get this job done.

Your motherboard should be entirely removed from the case. Get a nice work table set up where you have plenty of room and ventilation for your various tools and the board.

De-solder the old battery stand's legs and old solder off the board. Pretty self explanatory - get that old junk out of there. You'll know you did a good job when the glob of old solder is totally gone and you've got a perfect round hole in its place.

Step 4: Install the new battery kit
There are 3 post holes, which should be clearly evident on your board now. The excellent replacement kit is made so that it is impossible to install incorrectly these days, which is nice. Only just a few years ago one had to know which post hole was positive and which was negative yada yada. Worry not - that's all been sorted already for you. Using your soldering skills, put the new kit in place with 3 new and shiny little "teepees" of fresh solder. For me, I flipped the board upside-down and used a small brick of foam to put between the battery and the table. I used some masking tape to hold the kit in place, thus letting the new posts stick through the motherboard. I soldered these 3 posts, then snipped off the excess posts.
Motherboard upside-down, ready to perform the operation.

Finished, after snipping off the excess with some wire cutters.

Battery in place, top view.

If you've made it this far, you should be feeling pretty good about yourself. Well done!

Step 5: Reassemble your computer
Obviously you need to put everything back together. Isn't that heat shielding fun?

Step 6: Power Up and Set the Time
Again, this is for folks out there who are running 1.3 KS/WB environments, and particularly the 2000. This also assumes you have Workbench 1.3 installed to a hard drive. If not, why not?! ;)

Now, this is where things get a bit wonky due to the age of our machines, the various previous owners and what they might have done, or not done, along the way.

Once I got to this stage I figured, "I'm done!" I was wrong.

I could go to the CLI, and set the date and time. As a reminder, here's how to do that:

Code: Select all

 DATE 12:00:00 12-oct-85

Code: Select all

To exit the CLI, type EndCLI

Now, you could go to the clock widget in Workbench to test your clock. In my case, I use Dopus, which is an excellent file management tool. And when launched, it shows me the date and time across the top of my screen. Indeed, I have Dopus set to launch when Workbench launches as a small little strip across the top of my Workbench screen. It shows me the time as well as my memory usage, and is one click away from use, which I love.

I thought this was all I had to do. For some, I imagine this IS all they have to do.

I re-booted the machine. And.. the battery did NOT save the time or date. I was staring at 1-Feb-1978. No matter what I tried, the time would never save after I set it.

Thomas, via EAB:
Seeing it at 1978 means there is a battery backed up clock and it has either been reset or the battery is empty.
What the hell? How can that be?

But it would let me set it when the machine was on. The IC chip was working, remember? So maybe I screwed up the battery install somehow. That's what I thought, anyway.

I bought a multimeter ... and yes, my battery was fine. The traces on the motherboard appeared to be fine, too. What was going on? I really had no idea, and finally accepted defeat.

Fast-forward a few months, and I'm working on a totally different project. At the end, I needed to put my Workbench 1.3 floppy in the drive to use some tools. And that's when I noticed that, when I used the floppy disk, during the startup sequence I could see the real date and time! Right there, I could see it! But when I popped the disk out and rebooted to launch from my hard drive - it forgot the time and date again.


If this is happening to you, read on.

Step 7: The Startup Sequence

Using Dopus, I quickly inserted my WB floppy and read the startup sequence file in the S: drive. And there, in the middle of the file, I saw this:

Code: Select all

SetClock load ;
That little command tells the Amiga to look at the IC and load the date into memory! Seems baffling (and completely stupid) but if that command is missing, even if your IC can save the time, it won't show it on a reboot and will appear to have reset everywhere you look - to a date well before the Amiga was made! Completely idiotic, but it must've saved some really old machines a couple bytes of RAM back when every byte mattered.

So if you want to use your computer's clock without setting it manually every time, you need to set it as I described above. But you also need to update your startup-sequence to load it on each boot from the IC. Once you do that, everything should work flawlessly. And you should see the correct date and time when you launch your machine during the boot sequence wherever you placed that command in your file.
Startup-boot sequence showing the correct date and time!

And now on to installing productivity software! And I'll be leaving Dopus running all of the time with the time and date shown arrogantly across the top of my screen, every single day! <3
Dopus Strip which I have load on boot, showing the proper time now. It used to say 1978 after rebooting, even with the new battery installed and clock set in CLI. It only worked after updating the Startup-Sequence.

User avatar
Zippy Zapp

Posted Fri Mar 24, 2017 11:48 am

Nice post and glad you got it all sorted!

I am in battery mode for my Amiga's now as I am tired of setting the clock. I know what I am going to do for the A2000 and I ordered a Clockport RTC for my A1200 when I ordered the ACA500Plus. I got both of them a couple of weeks ago but have been too sick to mess with it. I hate seeing new stuff staring me in the face on my shelf. Ugh. The RTC for the A1200 clockport uses a CR1220 battery which is very small and nobody in my area sells it. I finally found one at a local Radio Shack that is going out of business but geez they wanted $8 for it. Thankfully everything was half off so it was only $4.

Goodbye Radio Shack. Too bad you couldn't have stayed as an electronics outfit all these years, maybe you would have survived in today's hobbyist electronics market.

User avatar
Seattle, WA, USA

Posted Fri Mar 24, 2017 12:07 pm

Nice post and glad you got it all sorted!
Thanks! I never would have guessed it was a startup-sequence issue. So happy I figured it out. I've been using WordPerfect Library since - totally fun nerdy geekery using productivity software on this bad boy!
I hate seeing new stuff staring me in the face on my shelf.
I know the feeling. The key, I think, is to not buy anything else until you get the new stuff figured out. Don't spread yourself too thin. ;)
Goodbye Radio Shack. Too bad you couldn't have stayed as an electronics outfit all these years...
For the life of me, I've never understood why RS didn't try to support the growing Maker market, in addition to the whole young kids coding phenomenon. All these little robots and whatnot kids can code using "scratch", which is sort of like coding with legos (blocks of pre-written code). It really could have been something special as they already had the real estate footprint. Need a cheap board to test some new idea on? Soldering irons? Etc. If you're trying to make stuff, you've got a source.

Ever since they threw their life preserver towards mobile phones it's been going downhill fast as far as I can tell. To think that they used to have their own brand of computers (and they were pretty good, too). Such a waste.

Return to “Hardware”