User avatar
mattsoft

Posted Fri Oct 06, 2017 9:07 pm

Bad news — the wicher does not work on a stock 1000. I just tried it on my other 1000 which is totally stock and all I get is the flashing power light. This is the same thing I get when I turn off the KS ROM on my rejuvenated 1000. So maybe the wicher needs the ROM to even boot. Total bummer. Eventually I’ll put a KS ROM on my stock 1000 and will try again. :(

User avatar
SEADRIVE

Posted Wed Apr 04, 2018 7:51 pm

Greetings,

I have a number of A500's, but aesthetically, would prefer to improve my A1000. Sorry to hear that perhaps it was looking for Kickstart 3.1 and a Fat Agnus?
...too bad to hear...we could use an external A500 solution, but I would love to have it internal with a CF card.

...let me know if you get it working please...and I will follow suit.

Joe Cimmarrusti
(Canada)

User avatar
SEADRIVE

Posted Wed Apr 11, 2018 9:36 pm

Because of the internal expansion possibility, I was going to grab a Wicher. However, the availability is actually low, I found many websites report that the A1000 did not work well with the wicher. Also, by the time one upgrades to 3.1 roms, and everything else the price ends up being slower overall and double the price of the ACA500 Plus, so last week I ordered this board. Regarding upgrading the Amiga 1000 agnus to a 1mb Fat Agnus, I would like more information. Nevertheless, good to see you are getting this working...I would love to see a youtube video showing your setup and such...cheers from Canada. :lol:

User avatar
Overmann

Posted Wed Aug 14, 2019 2:15 pm

Great thread! Are there any updates on this? I see they keep improving the firmware and adding features/compatability. Maprom was recently added. I just bought a stock A1000 (with the 256kb ram expansion) and I'm looking for a simple all in one to get kickstart 1.3, HDD and a bit more ram in my machine. The Witcher LOOKS like it should fit the bill and NOT require any soldering.

User avatar
A10001986

Posted Mon Aug 19, 2019 12:24 am

mattsoft wrote:Bad news — the wicher does not work on a stock 1000. I just tried it on my other 1000 which is totally stock and all I get is the flashing power light. This is the same thing I get when I turn off the KS ROM on my rejuvenated 1000. So maybe the wicher needs the ROM to even boot. Total bummer. Eventually I’ll put a KS ROM on my stock 1000 and will try again. :(
That's probably due to the badly written boot rom. IIRC it uses dbra-loops for timing, and that of course won't work on anything but the 7MHz original CPU.

User avatar
halfbrite

Posted Tue Jul 07, 2020 1:10 pm

mattsoft wrote:
Fri Oct 06, 2017 10:25 am
I've had a few people ask me about the CPU relocator board. So, basically it's a very simple PCB I designed using PCB123. I used Silver Circuits to fab the board. It basically just moves the CPU up and left of the floppy drive so you can plug a Wicher or Vampire (yes, the Vampire 500 works in this too) into the 1000 and keep your floppy stock (I love loading floppy disks, I know, I'm weird).

The PCB123 file is attached to this post if you want to order some yourself (minimum order is 4 IIRC from Silver Circuits). If you don't want to order 4, PM me and if I get enough interest, I can order another run and sell them at cost. I don't want to solder all the pins or go into business with this, but can provide you with links to the socket and pins you need.

Here is the file (broken link)
Does anyone still have these files, or can they point me to some that do the same specifically for the A1000? I was going to use the gerber files for the twin kickstart cpu relocater stickied at the top, but I am stuck using a twinkick II for now as I don't have the original chip nor do I know how to bypass the replacement if possible.

edit: I am guessing these are the originals





Return to “Hardware”