User avatar
Seattle, WA, USA

Posted Sun Jan 21, 2018 4:38 pm

Previous posts about the Amiga 1000 Phoenix board replacement project:
Part 1: Amiga 1000 Phoenix Motherboard Replacement Project
Part 1A: A1000 Phoenix Floppy Drive House of Horrors

After getting a good feel for the Phoenix board’s layout and capabilities, and eventually getting a viable floppy drive (FDD) to work within the confines of the A1000’s original case, there was one final major project that needed to be addressed: the hard drive.

The Phoenix board sports an internal built-in SCSI controller - something no Amiga 1000 ever offered. According to the original documentation and advertisements, this allowed Phoenix owners the astonishing prospect of having what all of the other expanded Amigas could have - an internal auto-booting hard drive. The problem? Figuring out how to do it! There is so little information regarding how to go about this, as the Phoenix used custom drivers for its SCSI controller.

Before going down that rabbit hole, however, I knew right off the bat was that I was going to need some hardware to even get this project started.

The Amiga 1000’s PSU only has one plug which goes directly into the motherboard. There are no additional wires for internal devices (e.g. like the Amiga 2000, which offers several internal expansion power options). Luckily, the Phoenix does come equipped with two power ports on the motherboard: one for the default floppy drive and and additional spare. That meant I needed to get an unusual conversion power cable - the type that are rather rare these days. I needed a 4-pin Floppy Power Female to a 4-pin Molex (LP4) Female plug. I couldn’t find one exactly like that, but settled on a Y-Connector version like this for $7:
I suppose I could snip off the unused male LP4 portion, but for now I’ve just left it alone as it isn’t hurting anything.

Hard Drive
The Phoenix Team originally offered optional mechanical hard drives - large Quantum drives - ranging from 52MB - 105MB. They could pre-install them for you or you could install them on your own. It did require cutting a very large rectangle out of the heat shield’s sheet metal in order to get it to fit in the original case (barely); the manual came with a template to use for the cutting.

To save space, conserve power and reduce noise (the Amiga 1000 is so gorgeously quiet) I decided to use an SCSI2SD card by Inertial Computing. I installed one in my Amiga 2000 last year (4GB, partitioned into 2gb/2gb) and I just love it. I decided that for my Phoenix Board, however, I would get a much smaller 256MB SD card. I did not purchase any of Intertial’s SD cards - I got my own via Amazon.

256MB SD cards are pretty rare these days, but if you find them they’re really cheap (e.g. $5). I got 2 - one for now, one to use as a future backup. If you follow my lead, make sure you get 256MB, not GB! My thought here was 256MB was between 2.5-5X the size of most drives in 1991 used with Amigas, and 256MB would feel gargantuan as well as last a very long time. Added bonus? It shouldn’t slow down my system hardly at all when I boot it up. Adding 4GB’s of HDD to my 2000 added an additional 11 seconds to its previous boot times. Not bad but certainly noticeable. And way more space than I really need, to be honest. I like the idea of modernizing the Phoenix’s HDD a bit, but also keeping it tidy and reasonable for my needs.

In the picture below, if you look in the upper-right corner you’ll see a little black jumper. That’s the LED light’s prongs. The black square next to it is the little SD card receptacle bay. That silver thing above the 2 capacitors is a USB port that you use for setting up the board via your modern PC/Mac machines, i.e. in my case setting the SCSI ID to 0 and writing those settings to the board, etc. I’ll save how to set these cards for use with Amigas on KS/WB 1.3 for another time.
Inertial Computing's SCSI2SD card (v5)

I got a little ahead of myself and simply assumed I’d get it all working right out of the gate (naive optimism or cocky ego?). I knew I was going to want to get an LED for the HDD to show when it was active. And, since I’m going to eventually use the original red LED for the FDD, I went with a very small red LED that I could plug directly into the SCSI2SD board. The board has it’s own light, which is great during testing to know what’s going on. But once installed and hidden inside the case, I needed something I could still see. I got one of these for $1.25.
It shines a nice warm red when attached to power. The light itself is cylindrical with a diameter of 3mm. Small enough to stay inconspicuous and also extremely easy to mod my front case using a simple, clean drill hole. I’d much rather drill a small hole into the case for this little light than some horrific Dremel experience. Those don’t often turn out very well, do they? No. Dremels are often a great way to make your 30-year old case look like a piece of garbage.

Almost looks like it was made that way back in the day, right?

So now I had all of the parts I needed to get a hard drive into the Phoenix. Now what?

Manual & Drivers
This is where the story gets a bit more convoluted and far less straight-forward, which closely matches my experience as I hunted for answers.

There is no “How-To” guide when it comes to the Phoenix. There was a manual of course, and a better-written one than most. But there was more than 1 motherboard revision, and a few custom drivers and other programs made for for each over a very long period of time. I never got the original disks that would have shipped with the Phoenix Board, though. That meant it was either to be found online, or not at all.

In terms of the manual, I do have an original paper version for revision 1.2, printed in 1991.

However, I believe mine is actually incomplete. It doesn’t have any in-depth content for the internal hard drive or how to install it. However, there is a digital version of the manual - for revision 1.3, also released in 1991 - which I was able to locate. And it has an entire chapter on the internal hard drive!

Back in the day, customers had the option of buying a pre-installed hard drive with their Phoenix boards or doing it themselves. Interestingly, there were only two hard drives supported in 1991 by Phoenix Microtechnologies - a Quantum drive of 52MB or 105MB. The Phoenix guys wrote scripts specific to those two drives… not very helpful today! Hah!

From the manual for revision 1.3:

This software is nowhere to be found. To my knowledge, the original disks are not available for download anywhere anymore. They’ve been lost to the sands of time, and maybe a few dusty attics.

In any case, over on the site there are a couple of Phoenix disks available for download. Some of the programs found on these disks are to test your hardware and some appear to include hard drive specific programs, including drivers.

I was never able to get any of them to work.

And lord did I try! It was beyond frustrating. If you follow the manual it refers to programs and drivers I simply didn’t have. If I followed the instructions on the floppy disks, stuff just didn’t work with my hardware.

Step one is to get drivers.
Step two is to correctly install them.
And step three is to use HDInstTools (version 6.9) - slightly modified - and set up your drive(s).

For the longest time no matter what I did the Amiga couldn’t get past step one. The disks I found from were not helpful in my case.

Over on Aminet, I found a driver written back in 1997 for the Phoenix SCSI controller. It is called Polled-pbscsi and was written by Erich Loew (Austria) and Gordon Fecyk (Canada).

Now this gets kind of involved, but in the disk there is a ReadMe document with its own installation instructions. There are two ways they outline how to use the drivers.

Option 1 works as a normal BindDrivers type driver, with the exception that it stays resident between soft reboots. You still had to use your WB floppy for the initial boot. Option 2 is the preferred solution if you have any non-autoconfig memory boards that also hook into ROMKickTag. As such I went for Option 1.

Going over to my Amiga 2000 and using Directory Opus 4, I did the following:
  • I took a Workbench 1.3 disk that I used specifically for the Phoenix Board and put it in drive df0:.
  • I moved the polled-pbscsi file to a formatted floppy via null-modem cable, and put that disk in the 2000’s df1:.
  • I ensured my WB 1.3 floppy had the ‘BindDrivers’ command in the C drawer
  • I then moved the files ‘Phoenix’ and ‘’ into the /Expansion folder on my WB 1.3 floppy (nearly filling it!)
  • I then modified the Startup-Sequence on the WB 1.3 disk with the following line:
    C/BindDrivers (my SS actually loads C: by default, so I really only had to add “Binddrivers” to one of the lines).
Next, I needed to ensure that the jumper L35 on the motherboard was disabled. It was. (It had been this whole time.) Jumper 35 is a hardware switch that controls auto-booting.

Finally, I put WB 1.3 into the Phoenix’s FDD and turned on the power. After Workbench loaded, I inserted and launched HDInstTools. I wasn’t told that the drivers were missing, but a quick scan showed no drives present. (Side note: it can get a bit annoying when you don’t have a hard drive set up and need to open other disks. Annoying because those other disks always want to refer to WB 1.3 on-disk, forcing you to switch back and forth between disks over and over.)

I’ve omitted the week of failures and struggles from this story - no sense in capturing all of that drama. But let it be known that I nearly gave up on this project. I was literally a heartbeat away. Exhausted and fed up one night I quietly left my computer room. After walking up the stairs from my basement and about to flick off the light a thought occurred to me.

Up to this point, one manual mentioned a driver called simply scsi.device. The Phoenix disks I’d found (and not gotten to work) had ‘pbscsi.device’ in them, although I’d never gotten those to work, either. This new driver I’d gotten on Aminet had no obvious drivers anywhere - just a program called ‘Phoenix’. On a last-gasp whim, I went to the HDTools icon, went to “Info” from the WB pull-down menu, and looked up the tool-type. It had originally been gvpscsi.device from when I’d last used it with my 2000. Earlier in the week I’d changed it to both pbscsi.device and later SCSI.device, which is what it was now. I switched it to pbscsi.device again even though the program I’d moved over was just called ‘Phoenix’ with no obvious device driver that I could see.

I scanned for devices once more.

BINGO! There was my scsi2sd card staring me back in the face, wondering what the hell took me so long. I couldn’t believe it!

This is not a guide on how to set up the scsi2sd on WB 1.3 - that’s for another day (soon). But I partitioned my 256MB SD micro card into two parts: 40MB for System, and 200MB for Programs.

I re-named and formatted my drives, and ultimately moved my entire custom Phoenix WB 1.3 disk to my new 40MB System drive using the following command:

Code: Select all

CLI> copy sys: dh0: all
You have to copy the custom Phoenix WB 1.3 disk over because it needs those Phoenix scsi drivers/programs, customized startup sequence, etc.

Once I was done with all of the hard drive business, the final test was to power off and back on again. I was so stoked! To be finally done… I turned the power off and back on again. And after seeing the HD LED blink briefly, I was staring at the WB 1.3 floppy request screen. Say what?! I put WB 1.3 into the floppy and loaded it up. There on my desktop were my two new hard drives! Sweet! But why didn’t it auto-boot WB on its own? 

After re-reading the polled-pbscsi ReadMe file, it looked like things were indeed working as intended. If I held down CTRL+A+A (Amiga keys) the machine would soft-reboot, and auto-boot right into Workbench. And holy crap, it was fast! I felt pretty happy about my choice to use a ‘small’ 256MB SD chip.

But what the hell? Why would they had done it this way? Was it purely for the set-up procedure?

Remember that part in the ReadMe earlier that said, “Disable the auto-booting of the ROM resident driver using Jumper L35”? Well, in my case that’s how the machine came. I never actually did anything for auto-boot to be disabled, hence why it wasn’t even on my radar. I found a jumper and pressed it onto L35 (it has 3 prongs, but L35 needs only a 2-prong jumper on the two right posts to enable it… I discovered eventually).

And now the Phoenix auto-boots, right into WB 1.3! So it loads KS 1.3 off its on-board ROM, and auto-boots WB off the hard drive.

All in the Amiga 1000 package! I think I’m in love. (If it was NTSC, I would be madly in love since most of my games are NTSC, but I’m not complaining.)

I want to hurry up and get the FDD’s LED hooked up and get this machine back together.

And then… a game? I need to get a game on this sweet thing! Decisions decisions. Maybe Populous II or Dune II. :)

I have experienced a very strange issue with the machine’s Auto-boot feature, which is hardware controlled on the motherboard via jumper L35. When I have auto-booting enabled, oftentimes the machine will freeze during a boot-up when it hits the HDD. If I disable it, power the machine on (let it hit the FDD), then turn the machine off - re-enable L35 - and power back up again, most of the time it will auto-boot off the hard drive for that session. But the next time I want to use the machine the auto-booting feature is goes dark again. If I disable the jumper and simply boot off the floppy, I can launch WB every time and even see my drives on the desktop. They work flawlessly. But something screwy is going on with the auto-booting piece. Last piece of the puzzle… I've been chatting with a guy from who has sent me a pbscsi "hack" he uses himself, which apparently increases the SCSI2SD's performance greatly with the Phoenix. Fingers crossed that it kills two birds with one stone, as I'm not sure how else to deal with this issue beyond simply disabling the auto-boot altogether. . . Definitely a bummer.

User avatar
Seattle, WA, USA

Posted Tue Jan 23, 2018 9:32 am


I've been working hard to see if I could resolve the auto-booting issue. I became a member of a German Amiga site - a fairly old one - called I met a very cool and knowledgeable guy over there who gave me all kinds of ideas on what to try.

The first thing I learned: I didn't actually need to install a separate power cable for the scsi2sd. The internal scsi controller uses what's called 'termpower' which means there is actually a bit of current that runs through the scsi cable. It's not enough to power most hard drives, but it is enough to power the scsi2sd card! As a result, I unplugged the power cord and put it back into my parts drawer.

None of the other tips have worked however. When I do put the jumper on auto-booting after fiddling in WB off the floppy, it auto-boots every single time - that first time only. And to watch it load WB in just 20 second flat is a thrilling thing to see. It kills me that as soon as I turn off the power and turn it back on again it hangs. . .

For now I've decided to take a break with the Phoenix's hardware. I'm proud to have brought the machine back to life; gotten the new floppy to work perfectly in its new home; and to have a 256mb hard drive working after booting into Workbench. It's pretty danged cool.

Last gasp update #2: I did get one last question last night from a new guy, asking me "Did you Setup the SCSI2SD device correctly ? Turn off SCSI2 and DISABLE Parity-checking! Set up the correct size of the used sd-card?" That, I can't remember. I used the default settings the scsi2sd utility pulled off of the thing. I suppose I can try and see what it says as one last experiment, but I'm not holding my breath. I'm pretty much resigned to this being what it is. And I'm OK with that. It's still pretty incredible.

User avatar

Posted Fri Jan 26, 2018 2:46 pm

I remember going the same tough road when I started with my Phoenix back in ... 2004 or 2005 or so.
Software wasn't really 'intuitive' back then. I went through the same [pb]scsi.device drama.
I am positive you will sort this out.
Once the Phoenix works it's like a heaven sent!!

User avatar

Posted Fri Jan 26, 2018 2:48 pm

Oh, and regarding the NTSC-mode of games...
I am under the impression that WHDLoad offers a switch (tooltype) to force the games or demos into NTSC.

User avatar

Posted Sat Jan 27, 2018 1:45 am

I opened my phoenix today, and took a screenshot of the settings of my SCSI2SD.

Good luck!

User avatar
Seattle, WA, USA

Posted Sat Jan 27, 2018 10:27 am

Nice! I think the only difference I can see there is the checkbox on the General tab for "Respond to short SCSI selection pulses"

The other differences (start sector, auto) I believe are because you aren't using the card as your boot drive, but for storage/programs. What do you use for your boot drive?

Thanks for the screenshots!

User avatar
Seattle, WA, USA

Posted Sat Jan 27, 2018 12:08 pm

I changed that one setting on my scsi2sd on my general tab as I noted above. For a brief heart-fluttering moment I thought we'd figured it out!

I powered the machine up after changing that setting on the card and it auto-booted in 20 seconds. So far so good, but not a good test. I powered off and back on again.

It auto-booted for a second time in a row! I'd not seen this behavior before! I swallowed and held my breath. I turned off the power a 3rd time and flicked it back on.

The card froze again on the autoboot. Arg! So close. I might muck around with a few of the other settings to try and see if slowing it down helps. I have a sneaking suspicion that since the card isn't your boot drive that's why you never see any issues with it. So close, though!

User avatar
Seattle, WA, USA

Posted Sat Jan 27, 2018 1:43 pm



I changed the Startup Delay from 0 to 1 seconds. I just auto-booted 3 times in a row with ZERO issues!! I can't believe it!!
Screen Shot 2018-01-27 at 12.40.46 PM.png
In the meantime, in my exctitement I ran to clean my french press coffee maker and sliced the end of one of my fingers off, bleeding all over the place. AND I DON'T CARE! WOO HOO!!

Guys! OMG. I think it's all done! <3 <3 <3

User avatar

Posted Sat Jan 27, 2018 3:44 pm

Glad it seems to work for you now. I know this feeling of triumph - priceless :) .
The SCSI2SD _*is*_ my boot drive, though.
Now that you mention it. I left the 10 blocks in the beginning because I had issues when writing the Filesystem to the drive without those blocks.

User avatar

Posted Sun Jan 28, 2018 1:46 am

Oh, one more thing ;) .
You should really get an Indivision ECS if nothing else. Doesn't hurt, blends perfectly into the system and you have VGA output available.
Woderful device.
A CPU relocator is also available on Aminet, though dubbed to be used with ther Vampire board.

If you want, we could exchange some info on options for the Zorro-Slot, even some quite non-intrusive ones :) .


Return to “Hardware”