User avatar
Seattle, WA, USA

Posted Tue May 22, 2018 9:17 am

Gawd. I just love the Amiga 2000.

In the background in-between a multitude of fun projects, I've been trying to get my Microbotics StarDrive to behave. The StarDrive provides a 3rd-party SCSI controller for Amiga 1000's. The only problem? It was written for ancient hard drives from back in the day. And if you don't own one of those really ancient drives, the only way to use it is to know your new drive's exact geometry.

And, most of that geometry is simply not published anywhere.

I originally tried to hook up a SCSI2SD to the StarDrive. I got it to see the drive and even format it. But the geometry was never right, apparently, and the disk would shoot off checksum errors soon after formatting.

Working with a friend of mine who also has a StarDrive, he decided to hook up an SCSI Iomega Zip (100MB) to his. I happen to have an old SCSI Zip drive from my art school days in the 1990s, and even saved a stack of disks. So I hooked mine up as well and we passed chats back and forth on what we seemed to get working for two days. Ultimately he got his to mount and work. It's a super slick setup. I, however, kept getting errors for some reason.

We both decided there was a good chance my Zip drive was bad, or the Zip disks themselves. I ordered a "brand new" unopened pack of Zip disks ($15 for 5 100 MB disks, shipped!) and even a new never opened Zip drive for a very reasonable price (IMO).

But then last night, while still waiting for the new Zip to arrive, I thought, "Why not plug it into the 2000? If it's the drive, then it should fail there, too."
The SCSI Iomega Zip drive looks right at home with the Amiga 2000.

Now, I have a lot of stuff plugged into the 2000. I have 3 SCSI devices: Original mechanical 40MB HDD, SCSI2SD 2GB HDD, and 44MB SyQuest internal drive.

Using a combination of HDInstTools and GVP hardware tools (to change the ID number) within about 15 minutes I had the Zip drive working on the 2000! No errors. And it mounts perfectly.
I had to use HDInstTools and a GVP hard drive program to get the Zip working - but only because I have so many SCSI devices attached. Under normal circumstances, it would have been a no-brainer (was still not bad to get working, though).

Every. Single. Time. The way it should!

So it's not the drive, and it's not the disks. I don't regret buying another Zip, though, as I'm not going to disconnect the Zip. I'm going to freaking USE it!

I then busted out Icon Master and modified a Zip icon my friend had sent my way as well. I tweaked it just right. Not bad, right? Gawd I love the 2000. And a 100 MB disk, that works like a fast HDD? Love. (It's so much quieter than the SyQuest, too). Makes me wonder if I should seriously consider replacing the SyQuest with an internal Zip at some stage.
Check out the SWEET icon for my Iomega Zip drive! Original art by Tim Kovak, updated and modded by yours truly. :)

I'm going to use this new geometry information and give the StarDrive one more go. Soon... Nice to bask in the glory of success for a little while first.

User avatar

Posted Thu May 24, 2018 1:52 pm

Please be also aware of potential maxtransfer and mask issues.

Especially with older designs.

I was pulling lots of hair out with the Phoenix not even booting (!) with an unpartitioned 128gb HDD attached to it.

User avatar
New Jersey, USA

Posted Thu May 24, 2018 6:19 pm

That is the most pimpin' Amiga 2000 setup I've ever seen! 10 year old me is drooling! :D

User avatar
Seattle, WA, USA

Posted Thu May 24, 2018 9:58 pm

Dang it. What does a guy gotta do to get the 40-year old you drooling? :)

(Thanks, I know what you mean!)

Return to “Hardware”