User avatar
Seattle, WA, USA

Posted Sun Apr 07, 2019 6:22 pm

A couple of months ago I acquired a *mint* boxed copy of Ultima 6 for Amiga. I picked it up after finishing Ultima IV for the first time as a reward to myself. I thought after IV, I’d eventually give 5 and 6 a go. (All of the Ultima games for Amiga are quite rare and difficult to source. I have Ultima V en-route it and should arrive any day now, completing the circle.)

When I got Ultima 6 in my greedy hands I quickly installed the disks to HDD. It installed flawlessly. I fired up the game and watched the intro, which is just epic. I then went through the process of creating my character in the gypsy caravan, which I’d seen before in Ultima IV. The difference now being the graphics were far improved.

After clicking through the various moral questions, I clicked on “Journey Onward” to begin the game and was instantly presented with this screen:
I was stunned. I just watched the entire intro and created a character, but was being told I needed a different. version. I couldn’t believe it! I’d finally found a copy of the game and it was hard-locked to PAL.

Usually if a game is written for PAL and it actually loads, there might be glitches in the UI. But in this case there is code that sniffs out your machine’s video mode and serves as gatekeeper. But it only rears it's head when you try to play the game. It lets you run the entire intro and character creation process. Such a tease!

Note: I did search for Ultima 6 ADFs and could only ever locate the PAL versions. And you never knew they were PAL until after you installed them and tried to Journey Onward. Kind of a pain.

I was left staring at my screen wondering what to do.

I could play the game on my A1000 Phoenix in PAL mode, but I really wanted the NTSC version. It obviously existed - all of the Ultima games were designed and developed in the US. So I started searching forums and, as is so often the case, a few tiny nuggets of similar queries were found but the answers were never detailed in how to resolve the problem (or if it even was resolvable using the original PAL disks). A friend of mine also loaded it up on his NTSC A1200, but using the boot options screen didn’t change anything for him, either. We were stuck.

I grudgingly created a long-term search for the NTSC disks. And I finally did find them! Talk about rare, folks. I have the only C64/C128 version of Ultima VI out of anyone I know. And now I'm the only person I know with the NTSC version of U6 for Amiga. (If you have it, please let me know!)
NTSC version with the purple sticker on the left. PAL version on the right.

Yep, this is indeed an NTSC specific print.

I paid a small fortune for the game on Ebay and was assured everything was tested and worked great.

It didn’t.
I finally found this extremely rare disk, and yet it had corrupted files. Massive hit!

There are 3 disks (an Install Disk and 2 Data Disks). When I tried to install to hard drive there were read/write errors from the Install Disk, and they were for files that were critical for the game to launch. I contacted the Ebay seller and he turned into a massive prick, basically smiling while shutting the door. “They worked for me! No returns!” As if I spent nearly $100 for a cardboard box and some manuals. That was the first 1-bomb I’ve dropped on a seller since using Ebay, and I’ve been using Ebay for a long time.

Regardless, I started to research disk repair options. I figured I had nothing to lose at this point.

The one program that kept coming up in conversations was written by the legendary Dave Haynie himself: DiskSalv.
Did you know Dave Haynie wrote commercial software for the Amiga? I didn't.

The most recent version was DiskSalv 4 and was released by Dave in 1996 or thereabouts as completely free (it had been commercial software previously).

I installed DiskSalv 4 to a floppy and then used its built-in installer to put it on my hard drive. But as soon as I booted it up I was greeted with an error message stating it required a minimum of OS 2.0! I run 1.3…

I did locate a DiskSalv version 1 from 1989 which was entirely CLI-driven, but it had no help files and I didn’t understand how to use it at all.

So I pulled my Phoenix down (which has both 1.3 and 2.0 via a hardware switch) and installed DiskSalv 4 to the Phoenix’s hard drive. I needed to give the Phoenix a little work anyway to keep her operational and happy.
Phoenix's need love, too, ya know.

I launched DiskSalv4 in OS2 and I have to say - it is VERY cool and easy to understand. I was able to scan the Ultima 6 Install disk and it did find errors. You get options to “salvage” files, or even have DiskSalv try to repair the disk. Salvaging allows you to select the files and move them to a new location (pretty danged cool).

I wasn’t sure which files were corrupted. Well, I knew of at least 2 files that would hang, but I wasn’t sure if there were more beyond that. I decided to go for the Repair option after salvaging some of the files into a new directory.
I flicked the disk’s write protection tab to Open, and told DiskSalv to Repair my original floppy. The program did its repair work for a few minutes reporting two distinct errors. Then, at the very end, it said the disk INSTALL had “Hard Write Errors” which it said it could not repair! My heart sank. I knew this was a massive long shot, but I’d held onto a shred of naive hope.

It also told me in very blunt and simple terms that the disk had write errors when I tried to close DiskSalv. Things seemed worse now than before.
For fun, I tried to install the game to the A1000 Phoenix one more time to see if the process changed at all (like, how bad did I really F* it up now?).

Guys - it fired 1 single error during the install, but this time the only file it couldn’t write was one of several “intro” files. Who cares about that?? I quickly tried the game launch - and it worked! I did see a glitchy sprite on launch, but it didn’t impact me playing the game one bit!

The DiskSalv program fixed most of the files, and more importantly it repaired the corrupted game files that really mattered.
I was never able to get to this screen before. For the first time, I was playing the original Ultima 6 in NTSC mode!

I was so excited! I could see the game was running a bit slow on the Phoenix’s 7Mhz, so I put the Repaired original Ultima 6 install disk in my accelerated A2000’s floppy drive. I wanted to install it fresh on the machine I intended to play the game with.


What DiskSalv did when it repaired the disk, believe it or not, was it changed the floppy disk to be only readable by OSes for 2.0 and above! OS 1.3 didn’t recognize the disk at all anymore. I couldn’t believe it. In repairing the disk, I'd undone its ability to run on 1.3 systems - its original target destination!

Then I had an idea.

First I copied all of the intro files on my A2000 to a floppy and over-wrote the broken intro files on the Phoenix. That removed the glitchy sprite I saw when I tried to play the game. Now the Phoenix’s NTSC install was 100% flawless. Cool.

Then, I fired up Directory Opus on both machines and went to both install locations on each machine. I compared the byte sizes of each and every installed file - the A2000 had the PAL version, the Phoenix had the NTSC version. I identified 5 files that were different between the two versions. Everything else was identical. I copied the 5 files I believed to be NTSC specific to a floppy (they all fit) and overwrote the same files on the A2000.
Comparing the PAL install to the NTSC install, I was able to quickly identify 5 distinct files with different byte sizes. Everything else was identical. I then copied the NTSC versions to floppy from one machine, and overwrote the PAL versions on the other.

I fired up the game on the A2000 one more time. I made my character then clicked Journey Onward. 
The PAL warning was GONE, and after a few moments, I was looking at the full game and talking to Lord British!
Hail! Hail!

As a result, I now have a reliable way for ANYONE to install Ultima 6 to their NTSC machines, and as long as they overwrite the same 5 files (which I shall provide soon), they, too, can convert their Ultima 6 to NTSC mode which in theory will run ever so slightly faster than the PAL version. Plus, the only ADFs I've ever seen out in the wild are PAL versions. So this could help quite a few folks here in North America and Japan.

It is a glorious thing. It's not 100% perfect, but it is damned good enough. Thank you Dave Haynie for DiskSalv!

(NOTE: I can’t make ADFs of the repaired NTSC Install disk. I mean, I could, but it would be for 2.0+ OSes, which would be wrong to distribute in my opinion. I will, however, provide the 5 files necessary for folks to covert PAL installations if they want to run the game on their NTSC machines.

If you have an original NTSC version of this game - please contact me! ADFs should be created and preserved as none seem to currently exist, and the original NTSC version should also be submitted to TOSEC when it is found again).

Until an undamaged NTSC Install disk can be found, you can now download the original PAL Disks (3 ADFs) from here.

Install the game to your machine's hard drive. (Note: you must boot from Floppy with the Install Disk to access the Installation menu).

Once that's done, take the files from this Zip archive and simply copy them on top of the PAL version. It removes the region lock entirely and lets you run the game normally as you would expect. You're good to go!

User avatar

Posted Mon Apr 08, 2019 11:19 am

This is awesome. I loved the Ultima games and only played up to Ultima V on the Amiga because I never could find Ultima VI at my local stores. They carried it for the C64, but not the Amiga. So I never got to play it.

Great work!

User avatar

Posted Mon Apr 08, 2019 3:46 pm

I have an NTSC version of ultima vi

User avatar
Seattle, WA, USA

Posted Mon Apr 08, 2019 6:13 pm

Oggie - does your copy work? Could you make an ADF of the Install Disk?

User avatar

Posted Tue Apr 09, 2019 1:40 pm

Awesome story. Never give up - never!
My wife calls this ‘stubbornness‘ :)

More important than adfs would be raw images made with a kryoflux or similar for preservation and archiving!

User avatar
Seattle, WA, USA

Posted Wed Apr 10, 2019 6:29 pm

After my original post I was contacted by (now member) Ogg1e on Reddit. He, too, had an original boxed NTSC version of Ultima VI!

After we shared several messages back and forth, he figured out how to create ADFs using Transdisk to his Compact Flash card, and then loaded the CF in WINUAE to pull the ADFs off to his modern hardware.

He then uploaded the ADFs to for all the world to go get! (I'll be hosting them as well, as I'm sure others will, too.)


Ogg1e, if you're reading this, you are my hero, brother.

User avatar

Posted Thu Apr 11, 2019 2:59 am

Really, please consider helping the CAPS project, see


User avatar
Zippy Zapp

Posted Thu Apr 11, 2019 11:41 am

That's good news!

I have been looking like mad for my backup copy that I made of a friends years ago but so far haven't found it. It is probably on an unlabeled disk some place.
McTrinsic wrote:Really, please consider helping the CAPS project, see

While I do appreciate the efforts of the SPA, you would need a flux imager, KryoFlux or SuperCard Pro to provide an image to them. Also, unlike, they do not share the images or preservation with anyone which makes it kind of pointless, IMHO. What happens if their building burns down and the preserved images go up in smoke? Of course, I realize they probably have off site backups, the whole point of preserving something like software is so future generations can enjoy it and experience history. With all can enjoy the archived software and so far most companies have been supportive or at the very least tolerant of the archive. Sorry I realize that was a bit OT.

User avatar

Posted Thu Apr 11, 2019 11:17 pm

I downloaded the game from and tried to WHDLoad it and it would not work. After a while, I found out that the file attributes seem to be messed up. The executable files are not executable for some odd reason. So that is why I think it won't run. (ie the file 'game') I didn't try to install it on the HD the normal way under 1.3 though...

User avatar
Seattle, WA, USA

Posted Fri Apr 12, 2019 9:58 am


Ogg1e told me when he first created the ADFs:
I figured it out using transdisk to the cf and then loaded the cf in winuae to pull them off.
But I'm not 100% if he tested the resulting ADFs or not. Let me try to get more info. You're now the 2nd person to reach out and tell me there are WINUAE issues. Creating a real floppy with his ADF would be the crucial test in my mind. But let's see if Ogg1e can chime in.

Return to “Software”