Amiga OS, Workbench and Kickstart, Utilities, Optimizations, Hacks and all things file/usage related
User avatar

by TomCorbett posted Sun Jun 10, 2018 4:53 pm

I am wondering if anyone has familiarity or experience with Bootman. I got my A2000 on Ebay a number of years ago, and recently brought it out of storage, found the battery backup cap had leaked an rendered it inoperative. I got a working A2000 from Ebay, and with much difficulty including having to get my GVP 68040 accelerator card fixed, I got it up and running. Then my stupidity struck. It was booting up using what I have since found to be a boot selector program called Bootman, and booting a setup that was listed as OriginalStartup. Well this sequence would boot and then request a volume HELP be put in any drive, I had no Idea what this was, so I cancelled it, and the booting proceeded normally from there. But I wanted to get rid of this , and so I thought if I cleared out the bootman selection window it would just boot straight into the 3.1 workbench installed on the hard drive. Nope, by doing that I bricked the booting routine, the boot process would start and hang, probably where the Bootman was suppose to display it's menu. I can boot into Workbench 3.1 from a floppy, and the 244mb hard drive divided into 2 partitions DH0 and DH1 were available.I have been unable to find Bootman unless I run a program called OPUS 5, then I find it in a directory called s. But I can not execute any program from OPUS 5. I tried a Command Line interface, but s is not available, and if I open the DH0 window, it is also not available. There is a Bootman Pref file in the Prefs? drawer, but while I can get it to run (not in OPUS 5), and am able to add a startup sequence to the bootman menu that shows up, it seems to only be for the floppy drives as DF0 through DF3 as drives available. So I am lost as to how to get my booting sequence back. Anyone have ideas cause I am not happy with having a paperweight as big as the A2000 on my desk (LOL).
User avatar
Seattle, WA, USA

by intric8 posted Sun Jun 10, 2018 8:42 pm

Are there files on the HDD that are precious?

If the answer is "No" you could simply start over. As such you would boot off Workbench disks, then fire up HDToolbox or HDInstTools. Then, you would format and partition the drive as you wish it to be (like DH0: and DH1: just like before). After that, you would open a CLI window (via the WB floppy) and copy WB from FDD to HDD. It would look something like this:
Code: Select all
COPY DF0:#? to DH0:
After that, you should be able to pop WB out of your floppy, reboot, and be looking at your new HDD ready to install various programs of your choosing.

If you're not ready or wanting to start over, another option would be to look inside your Startup-Sequence. You have to open a CLI and go to 'S' drawer.
I'd look in there and see if it is being Assigned. If it is, but you deleted part of the program, that could cause some funkiness for sure. I would also pop over to your mountlist file and look to see if Bootman was mounting anything funky over there, too. Those are the 2 key files WB looks at during bootup.

To get to the "s" directory, you would call it up like this. Assuming you booted WB up off the floppy drive but want to work on your hard drives....

Code: Select all
cd DH0:s

Even though you'll be booted up off the floppy, that will tell it to seek out DH0: and get to the 's' directory. From there, you could then load up your startup-sequence.
Code: Select all
ED startup-sequence
(It is not case sensitive.)
ED uses a built-in editor that allows you to read, edit and save text files. Startup-sequence is a very sensitive and special file. Look for anything that says "Bootman" in there. If you want to leave the file and NOT make changes, you hit "Esc" then the letter "Q". That will quit, and it will tell you if you do, you'll lose any changes (if you made any) and you'll say Yes.

If you do make changes in there (e.g. if you press CRTL and the letter B, it will delete an entire row) and you want to save those changes, you would hit the ESC key and then the letter X. That will save your changes to the file. You can reboot and see if your edits worked.

My guess is the Bootman program was being called somewhere in your Startup-sequence. There's a mild chance it might have even modified your user-startup file or the mountlist in DEVS.

But if you don't have precious files on there, you could just start from scratch and clear things out. Or, an even different approach would be to re-install Bootman. But I'm guessing you probably won't really miss it.
User avatar

by TomCorbett posted Mon Jun 11, 2018 4:47 pm

Thanks for your quick answer, you have given me some leads to look at to save the info on the drive. It is precious in that some of the programs on the DH0: partion are virtually irreplaceable. There is a copy of Super Jam to go with the Blue Ribbon sound card in the computer, something called shapeshifter (a MAC emulator I think), MagicWB, some online program called Miami, one of the neatest graphic renditions of the Starship Enterprise, and other that I have not gotten to look at. So I will investigate the files and drawers you pointed me at, and try to get back with a status. I understand you are from Seattle, right? I use to live there moons ago, born in Tacoma, spent the first 19 years of my life in Washington state (Seattle, Puyallup, Longview and a short stint in Portland, until I enlisted in the Air Force in 1961 (yeah I know I'm ancient, lol). Anyway will get back in a couple of days as I still have to work full time to make my world go round. Tom
User avatar
Seattle, WA, USA

by intric8 posted Mon Jun 11, 2018 7:15 pm

OK Tom, good luck. Feel free to drop back in here.

Yes, I'm in Seattle. I was not born here - I moved here in 2011. I simply love it and hope we never have to move. I think I've found my settlin' down place finally. Took me long enough (I'm 46).

By the way - I was in the Air Force, too. I wasn't in for a lifetime. It wasn't really my thing. But I met a lot of very cool people and had some incredible experiences while I was there. Feels like another lifetime at this point.
one of the neatest graphic renditions of the Starship Enterprise

OK, that file right there I'm going to have to get a copy if you figure things out. And if you don't know how to do that, I can try to help with that as well. :)
User avatar
Seattle, WA, USA

by intric8 posted Tue Jun 12, 2018 2:01 pm

By the way, Tom, you should also take a peek at the User-Startup file that may be inside your S drawer.

Some (aggressive) programs will install little bits of code and/or assigns in the User-Startup. This is suppose to be a less "destructive" approach to creating a customized boot sequence without dirtying up your startup sequence file. So if you still have trouble, you after looking into your startup sequence, a user-startup would be another place to investigate.

AmigaOS Manual:
A User-startup file is the Shell equivalent of the Workbench WBStartup drawer. It is a text file that is executed as a script by the default Startup-sequence. Place here any configuration commands, such as ASSIGNs, and the names of programs you wish to run automatically whenever you boot.
If you go to the startup-sequence and it looks totally clean, I bet it's being called in the user-startup.
User avatar

by McTrinsic posted Sun Jun 17, 2018 1:12 am

If there is something precious on these disks: get an USB-SCSI adaptor from eBay and learn how to make a backup in WinUAE on a PC.
Just DONT format the drive when Windows suggests it when you plug it in.
User avatar

by TomCorbett posted Sat Jun 23, 2018 3:40 pm

Ok, this is many days later, and it is because I found on looking at the startup-sequence, the user-startup, and a couple of other files , that things get complicated, mostly because I did not understand well the commands used in AmigaDOS. I have tried to learn a bit about them, but my time has been gobbled up by work, and being sick with acute bronchitis. I have found that the startup-sequence file on my harddrive DH0: is very simple, and that is where BootMan is called up. my problem is that I do not know what happens if I comment out that line in the program, because then the only instructions left seem to execute user-startup. I mostly am at a loss as to what files BootMan tries to start, and why it has no error trapping to prevent happening what I did, that is remove all the menu choices in BootMan, so it locks up and stops the boot process. I am enclosing jpgs to show the listing of the booting files, in the hopes that you guys are a lot more knowledgeable than I am. For example, is the user-startup file what I would want to run if I removed the BootMan program from executing? or should I get either the starseq or startup-sequence.hd to run instead. it took me some time to find pin feed paper at a reasonable price, and to get new ink cartridges for my Star Micronics NX2420 Rainbow printer. The number of lines in most of the executable files was too long for an error prone guy like me to copy. So please take a look at the pictures and ssee if you have an idea what they will do. Each of the possible startup-sequence seems to call the user-startup file at the end, so user-start up should probably stay the same. Pleas note that a good portion of my troubles are because I did not get any of the program installer disks for the multiple programs I have on the hard drive. I don't even seem to have the GVP installer disk for the 68040 accelerator card. The program lists are fairly clear, and the hand written ID's are from the directory of the hard drive s file. Another puzzle to me is the hard drive files do not seem to use case sensitivity, but the Workbench 3.1 floppy does (S dir vs s dir, startup-sequence vs Startup-Sequence [the caps are all on the floppy directory. Tom [OK, someone will have to show me how to add pictures, because I do not seem to be able to do that.]
User avatar
Seattle, WA, USA

by intric8 posted Sat Jun 23, 2018 6:31 pm

Tom when you post here look for a red link below your post “upload attachment” below the Preview button.

Click on that red link below the main form. It will give you a Choose file button to add attachments (images) to a post.
User avatar

by Dynamic_Computing posted Sat Jun 23, 2018 7:46 pm

Commenting out files in startup-sequence is usually harmless - if it breaks something, reboot and hold both mouse buttons down. From the startup screen that appears, choose "no startup sequence" and it should boot to a CLI (command) prompt.
Type "run ed s:startup-sequence", change back what killed your boot, hit esc and then choose the option to save. Reboot, and you are back where you were before.
@10marc1 on Twitter
User avatar
Seattle, WA, USA

by intric8 posted Sun Jun 24, 2018 8:00 am

As I mainly live in OS 1.3-Land, I totally forget about these tricks. I've grown used to getting around them by default. So, yes - that's a great idea.

It's worth noting that if you do comment out a line and your boot-up breaks, you can often still run off your floppy to boot up instead. Just be sure your WB disk is write protected. When you boot off a floppy and need to work on your HDD installed WB, it can get a little confusing at times. You may try to open your SS on your HDD, and notice it's reading your floppy disk. "Is that just to launch ED? What's it doing?" You won't really know until the file loads if you loaded the correct one.

Tom - do post pics of your SS and User Startup files when you can. Here are some tips on how to navigate the CLI (stopping text scrolling, etc.) for taking your pics. This is another reference I use often. I use "CTRL-B" a lot for blanking out entire lines - super handy.

Who is online

Users browsing this forum: No registered users and 1 guest