User avatar
m4d

Posted Sun Aug 09, 2020 8:06 am

sirimax wrote:
Sun May 24, 2020 3:22 pm
I don't understand... Why?
I had the same problem and for me the solution was to build an adf in WinUAE. I created the KICK31.ROM in a OS3.1 session with GrabKick, put it in the same directory as TKG.EXE and then executed TKG.EXE in a Kickstart/Workbench 1.3 session.

Things i learned along the way:
  • Rom images i found on the net because i was lazy were not recognized
  • Naming of the roms has to be uppercase.
  • Patched Kickstarts don't work at all
Good Luck!

User avatar
Marchie

Posted Sun Aug 23, 2020 6:51 pm

Hey,

I managed to create the Twinkick disk, but instead of taking me to the boot screen I just end up at a 3.1 DOS prompt. Soft-reset just hangs the machine on a grey screen.

Anyone else experienced this?

User avatar
Marchie

Posted Mon Aug 24, 2020 6:37 am

Ok, so my DOS prompt was just that it was booting to a HDD with nothing on it. And you MUST hold down a mouse button on reset - learning, learning. This is kind of fun...

User avatar
BatteMan
France
Website

Posted Mon Aug 24, 2020 11:53 pm

Here, I created a Dual Kickstart Boot but it doesn't work. I think the memory on the Classic 520 doesn't allow it... Or I failed with my floppy :lol:

User avatar
Marchie

Posted Wed Aug 26, 2020 4:17 pm

You have to use Grabkick on real hardware to extract the 3.1 ROM - at first I used an emulated system and it just wouldn't work. Then you have to run the Twinkick program from your A1000.

It's a pretty temperamental exercise - I have found the reset to be really unreliable so far, hangs most of the time. So much so that it's not really use-able, a machine that you can't soft-reset is actually not much use.

EDIT: User error - no reset problem at all, I have the machine out on a test bench and it was shorting!

User avatar
m4d

Posted Sat Aug 29, 2020 4:23 am

Marchie wrote:
Wed Aug 26, 2020 4:17 pm
You have to use Grabkick on real hardware to extract the 3.1 ROM - at first I used an emulated system and it just wouldn't work. Then you have to run the Twinkick program from your A1000.
As I wrote above I've created my TwinKick in WinUAE and it totally works.

User avatar
maurensen

Posted Thu May 13, 2021 11:39 am

Hi,
I'm trying two kick with my 1000 equipped with hc520 expansion.
I managed to create the disk but I'm only able to boot to 1.3.
Inserting twinkick disk disabling kickstart on the hc520 the floppy loads 1.3 but I'm unable to switch to 3.1. am i missing something (i followed step to step the procedure to create the disk so i put kick13 and 31 on the disk before creating it).
Any thoughts? Thanks!

User avatar
m4d

Posted Sat May 15, 2021 11:08 am

That's strange. It should find the fastmem of your hc520 and load right after showing the 1.3 kickstart hand. Did you try leaving the Twinkick disk in?

User avatar
maurensen

Posted Sat May 15, 2021 10:54 pm

Yes, the disk is continuing to read and the screen is flashing but nothing more....

User avatar
m4d

Posted Sun May 16, 2021 3:19 pm

Sorry, no idea then. While a bit finnicky in the making process my TwinKick just worked once i got it right.





Return to “Software”